Warning: Use of undefined constant ‘xmlrpc_methods’ - assumed '‘xmlrpc_methods’' (this will throw an Error in a future version of PHP) in /var/www/html/wp-config.php on line 84
OpenSSL 1.1.1 < 1.1.1k Multiple Vulnerabilities | ShieldNow

La versión de OpenSSL instalada en el host remoto es anterior a 1.1.1k. Por lo tanto, se ve afecta-do por diferentes vulnerabilidades.

– El indicador X509_V_FLAG_X509_STRICT permite verificaciones de seguridad adicionales de los certificados presentes en una cadena de certificados. No está configurado de forma predetermi-nada. A partir de la versión 1.1.1h de OpenSSL, se agregó una verificación para no permitir certifi-cados en la cadena que tienen parámetros de curva elíptica codificados explícitamente como una verificación estricta adicional. Un error en la implementación de esta verificación significó que se sobrescribió el resultado de una verificación previa para confirmar que los certificados de la ca-dena son certificados de CA válidos. Esto evita de manera efectiva la verificación de que los certi-ficados que no son de CA no deben poder emitir otros certificados. Si se ha configurado un propó-sito, existe una oportunidad posterior para verificar que el certificado sea una CA válida. Todos los valores de propósito nombrados implementados en libcrypto realizan esta verificación. Por lo tan-to, donde se establece un propósito, la cadena de certificados seguirá siendo rechazada incluso cuando se haya utilizado la bandera estricta. Un propósito se establece de forma predeterminada en las rutinas de verificación de certificados de servidor y cliente libssl, pero una aplicación puede anularlo o eliminarlo. Para verse afectada, una aplicación debe establecer explícitamente el indi-cador de verificación X509_V_FLAG_X509_STRICT y no establecer un propósito para la verificación del certificado o, en el caso de las aplicaciones de cliente o servidor TLS, anular el propósito pre-determinado. Las versiones 1.1.1h de OpenSSL y posteriores se ven afectadas por este problema. Los usuarios de estas versiones deben actualizar a OpenSSL 1.1.1k. pero una aplicación puede anu-larlo o eliminarlo. Para verse afectada, una aplicación debe establecer explícitamente el indicador de verificación X509_V_FLAG_X509_STRICT y no establecer un propósito para la verificación del certificado o, en el caso de las aplicaciones de cliente o servidor TLS, anular el propósito prede-terminado. Las versiones 1.1.1h de OpenSSL y posteriores se ven afectadas por este problema. Los usuarios de estas versiones deben actualizar a OpenSSL 1.1.1k. pero una aplicación puede anularlo o eliminarlo. Para verse afectada, una aplicación debe establecer explícitamente el indicador de verificación X509_V_FLAG_X509_STRICT y no establecer un propósito para la verificación del cer-tificado o, en el caso de las aplicaciones de cliente o servidor TLS, anular el propósito predetermi-nado. Las versiones 1.1.1h de OpenSSL y posteriores se ven afectadas por este problema. Los usua-rios de estas versiones deben actualizar a OpenSSL 1.1.1k.
OpenSSL 1.0.2 no se ve afectado por este problema. Corregido en OpenSSL 1.1.1k (Afectado 1.1.1h-1.1.1j).
(CVE-2021-3450)

– Un servidor OpenSSL TLS puede fallar si un cliente envía un mensaje ClientHello de renegocia-ción creado con fines malintencionados. Si una renegociación de TLSv1.2 ClientHello omite la ex-tensión signature_algorithms (donde estaba presente en la ClientHello inicial), pero incluye una extensión signature_algorithms_cert, se producirá una desreferencia del puntero NULL, lo que provocará un bloqueo y un ataque de denegación de servicio. Un servidor solo es vulnerable si tiene TLSv1.2 y la renegociación habilitada (que es la configuración predeterminada). Los clientes de OpenSSL TLS no se ven afectados por este problema. Todas las versiones de OpenSSL 1.1.1 se ven afectadas por este problema. Los usuarios de estas versiones deben actualizar a OpenSSL 1.1.1k. OpenSSL 1.0.2 no se ve afectado por este problema. Corregido en OpenSSL 1.1.1k (Afecta-do 1.1.1-1.1.1j). (CVE ‑ 2021‑3449)

CVE: CVE-2021-3449, CVE-2021-3450
Factor de Riesgo: Medio
Valor CVSS Base: 5.8

Solución

Actualice OpenSSL versión 1.1.1k o posterior más estable

https://www.openssl.org/source/

Referencias

https://www.openssl.org/news/secadv/20210325.txt

 

No Comment

You can post first response comment.

Leave A Comment

Please enter your name. Please enter an valid email address. Please enter message.

You may also like